Problems with protocoll in Server

I wanted to export my data from Interviewer via connection to Server. An error occured and said, that my protocol used by the Interviewer session has not been imported into Server. I should import it to Server first and try again.
When I try to import the protocol to Server (after checking if it is the correct one!), Server is telling me, that the protocol has already been imported.
So what am I supposed to do now?

Hi Maren. Thanks for signing up and creating this post!

My name is Joshua, and I lead the design and development of the software.

I’m so sorry to hear about this problem! It sounds to me like you have encountered a bug in the software - please accept my apologies.

I have a few questions to help me understand the issue better.

  1. Had you already uploaded data to Server prior to encountering this issue?

  2. Were you previously able to create a workspace in Server using this protocol, which subsequently disappeared? Or is this your first time creating a workspace?

  3. Finally, are you able to create a workspace in Server using any other protocols (You can download a sample protocol here to test:

Assuming that you have not yet stored any data with Server, my advice would be to first use the “reset app data function” (from the app, click “develop” → “reset app data”), and if that doesn’t work, try uninstalling the application, and then installing it again.

Please let me know how you get on.

Hey Joshua,
thanks for the fast help. To answer your questions:

  1. Yes I uploaded data to Server before. But it was luckily only test data.

  2. I was able to create the workspace using this protocol and it disappeared at some tiome point.

  3. I tried your suggestion and was able to create another workspace using this test protocol.

Your suggestion to reset the app worked quite fine. But assuming, that this problem will occure later on, while there will be already data on server. How can I save this data before reseting Server?


I’m really glad it was only test data that you lost, but I share your concerns about this happening again.

Unless we can work out what specifically is causing the issue in your case (and get reproduction steps), we can’t explore a fix for the issue. If you are able to reproduce the problem, please document the steps so that we can work on a proper solution.

In the absence of that, my general advice to you (and all users) is to only use Server if your study specifically requires it. If you don’t have multiple devices that need to send data to a single location, and if you are able to use manual file transfer or a cloud-based storage system, please export your data directly from the Interviewer app. More info about this here: Using Server to manage a study - Network Canvas Documentation

Thanks again for taking the time to report your issue.