Issue with saving changes protocol in Architect

It has happened to me a few times that after working for a long time on a protocol, the “save changes” button in the general screen of the protocol disappears, making it impossible to save changes before going to the start screen. I’ve just tried in that case creating a new stage and saving that to see if the button “save changes” appears again, but it didn’t.
Any idea about what the issue can be and what to do to avoid that from happening?
I’l working on a Mac, in case that information matters.

Hi Maya

This sounds like you are encountering a bug in Architect. The save button is disabled when the app detects that the protocol has become invalid, somehow.

Could you please try to recreate the specific series of steps that cause this to happen? For example, which interface are you editing, and what edits do you make?

Once we have that, we can track down the issue.

Hi Joshua,
After losing my changes, I tried to quickly redo them, and didn’t encounter issues. Hence my impression that it happens when I work on the protocol for a long time without saving the protocol regularly (even though I obviously save the changes in each interface and stage), which happened previously as well.
But will try to keep an eye on this if it happens again.

Thank you Maya. This must be very annoying - I’m sorry this is happening!

If it happens again, there is one thing you might be able to do to help us. There is a developer console within the app that shows errors that might not be shown to the user. To open this console:

  1. Click “Develop” → “Toggle Developer Tools”

Screenshot 2023-06-01 at 11.05.53 AM

  1. A window will open called the “console”. Error messages will be displayed here (usually in red, but not always). You should expect to see something about the protocol being invalid. Copy and paste anything that looks like an error into this thread. Use the arrows to expand any items so you can see any nested data within them

You can also share a screenshot of the error here. Please try to include as much text as possible, and as much information about the last thing you did so that we can get this fixed.

1 Like

Hi Joshua,
This time the issue with saving changes happens after making changes to a stage, at the stage level itself.
Not sure whether this screenshot of the console will be useful for you guys:

Ah it seems it was linked to the fact that I didn’t add a filter to the nodes to show in the side panel?
Seems ok now. :slight_smile:

Now have the same issue as the first time - impossible to save changes at the protocol level (the save button just doesn’t show after saving the changes at stage level).
Here a screenshot of the error in the console:

I found where the mistake was thanks to this error message, but still strange that it allows to first save the changes at stage level, but then later makes it impossible to save the changes at protocol level.

Hi Maya,

Thanks so much for taking the time to share screenshots of the error here. I’ve been able to identify the bug and am actively working on a fix now.

Hi Maya,

We’ve identified that there are two bugs you’re encountering, and need more information about one of them to reproduce it and fix it. Sorry this is happening!

It would be most helpful to know what changes you are making before the save button disappears after saving changes at the stage level. Particularly:

  • What interface type are you making changes on?

  • Are you adding or removing validation on variables?

Any other specific information you can provide about exactly what changes are being made before the button disappears will be helpful!


Hi Caden,
It has happened at several occasions with different types of interfaces., and I think both with validation and variables. But I will try to describe the latest encounter I had.
I was working on an ego form and had changed the validation type. I had then moved to another interface type (don’t remember which one), and when coming back to the main protocol screen, the save button had disappeared. But then I saw in the error messages in the console that there was an error with the change of the validation type.
Not sure that helps?

Just happened again, this time updating a the data source for a roster interface.
As you can see in the screenshot, I continued working a bit, and after saving changes for the stage, the save button disappeared in the main protocol screen.
Let me know if you want me to send more details from the console etc.

Hi Maya - Are you available for a quick meeting so that we can get to the bottom of this? Unfortunately we need more details than we can get from just a screenshot.

If you are, please join me at the following link: Launch Meeting - Zoom

I will leave this open for the rest of the work day on the off chance that you are available :slight_smile:

If you can’t make today, please email with your availability next week.

We are really sorry about these issues, and very grateful for you for bringing them to our attention!

Hi Joshua,
I can meet now? But your zoom link doesn’t lead to a specific room/meeting :slight_smile:
If you prefer further contact by mail:

Hi Maya

I’m pleased to say that we found several problems as a result of your help, and were able to fix them all in the latest version of Architect (6.4.5). Please download it, and let us know how you get on.

We could not have found these problems without you. Thank you SO much for the time you took to report and help us debug. If you encounter any other issues, don’t hesitate to get in touch.

As a side note, I have to tell you personally how impressed I was with the protocol you developed. It is the most sophisticated and well put together of any study I have seen using our software yet - bravo!

1 Like

Thank you so much, and for solving the bugs promptly, and for the compliment about the protocol, that means a lot! I’m new at all this, so really, thank you!

1 Like

Hi, I am having the same issue where the protocol save button disappears. After reading the threat I tried to download the latest version of architect (I’m working in 6.4.3) but when I click the link for the windows download ( I am given a 404 error saying this page is not found.


Apologies for the broken links - I have updated them now.

The latest version of Architect is now 6.5.0.